mirror of
https://git.sr.ht/~rouven/nixos-config
synced 2024-11-14 21:03:10 +01:00
34 lines
784 B
Nix
34 lines
784 B
Nix
{ config, ... }:
|
|
{
|
|
imports = [ ./fixes.nix ];
|
|
nixpkgs.config.allowUnfree = true;
|
|
users.users.rouven = {
|
|
description = "Rouven Seifert";
|
|
isNormalUser = true;
|
|
extraGroups = [
|
|
"wheel"
|
|
"video"
|
|
"dialout"
|
|
"libvirtd"
|
|
"docker"
|
|
"tss"
|
|
"input"
|
|
"wireshark"
|
|
"etherape"
|
|
];
|
|
initialHashedPassword = "$6$X3XERQv28Nt1UUT5$MjdMBDuXyEwexkuKqmNFweez69q4enY5cjMXSbBxOc6Bq7Fhhp7OqmCm02k3OGjoZFXzPV9ZHuMSGKZOtwYIk1";
|
|
};
|
|
home-manager.useUserPackages = true;
|
|
home-manager.useGlobalPkgs = true;
|
|
|
|
home-manager.users.rouven = { ... }: {
|
|
imports = [ ./modules ];
|
|
|
|
config = {
|
|
home.username = "rouven";
|
|
home.homeDirectory = "/home/rouven";
|
|
home.stateVersion = config.system.stateVersion;
|
|
};
|
|
};
|
|
}
|