mirror of
https://git.sr.ht/~rouven/nixos-config
synced 2024-11-15 05:13:10 +01:00
24 lines
598 B
Nix
24 lines
598 B
Nix
{ stdenv, fetchFromGitHub, lib, libmilter, db }:
|
|
stdenv.mkDerivation rec {
|
|
pname = "hashcash-milter";
|
|
version = "0.1.3";
|
|
src = fetchFromGitHub {
|
|
owner = "zholos";
|
|
repo = pname;
|
|
rev = "v${version}";
|
|
hash = "sha256-yVpfvwpZUZQppZpmXmAqjoZH5shWUnA8aMVSOkPyQXw=";
|
|
};
|
|
buildInputs = [ libmilter db ];
|
|
installPhase = ''
|
|
mkdir -p $out/bin
|
|
install -m 755 -p -s hashcash-milter $out/bin
|
|
'';
|
|
|
|
meta = with lib; {
|
|
description = "Hashcash Milter";
|
|
license = licenses.bsd3;
|
|
platforms = platforms.linux;
|
|
maintainers = with maintainers; [ therealr5 ];
|
|
};
|
|
}
|